64x64.png?1.2
LiteSpeed Extension

Version
1.2.6-1
Author
LiteSpeed Technologies Inc.
Homepage
https://www.litespeedtech.com
Documentation
https://www.litespeedtech.com/support/wiki/doku.php/litespeed_wiki:plesk
Platform
Linux
Plesk Version
12.0.0 and up
Category
Web Servers
Average Rating
(3.2)
Votes
5

Description

Double the maximum capacity of your Apache server with LiteSpeed! This extension allows you to install and manage LiteSpeed Web Server from Plesk. **Note:** To start using this extension, perform the following steps to stop nginx: 1. Go to **Tools & Settings** > **Services Management**. 2. Stop **Reverse Proxy Server (nginx)**. [Read](https://www.litespeedtech.com/support/wiki/doku.php/litespeed_wiki:plesk:installation-12) how to install and configure LiteSpeed Extension. # Licensing LiteSpeed Extension is **paid**. To start using it, you need to: - Request a LiteSpeed Web Server trial license via the extension GUI. - Purchase a LiteSpeed Web Server license and type its serial number in the extension GUI.

Changes

# 1.2.6 * [-] Fixed PHP 7.1 errors in version manager in preparation for Plesk Onyx 17.8. # 1.2.5 * [*] Added support for multiple PHP versions through Plesk's PHP selector. # 1.2.4 * [-] Fixed scripts when switching between Apache and LiteSpeed on CentOS7 and Debian (where systemd is used). # 1.2.3 * [+] (CentOS) Added the ability for users to choose a PHP version when the corresponding RPM package is available. * [*] Plesk will now detect if Nginx reverse proxy is running and display the following error message in the page header: "LiteSpeed cannot run if nginx proxy is running". * [-] Fixed installation directory error on Debian/Ubuntu platforms. # 1.2.2 * [*] Override of /etc/init.d/httpd with LSWS's rc script for faster adding/removing of domains in Plesk 12. # 1.2.1 * [*] Plesk installation directory is now auto-detected. # 1.2 * [*] Default LSPHP now contains more packages for greater overall compatibility. # 1.1 * [*] Improved compatibility with Plesk 12. # 1.0.3 * [*] CageFS skeleton will get updated PHP after LSWS installation. * [-] Created a workaround in response to PHP bug #66842 (latest version of PHP unable to make install). # 1.0.2 * [-] Fixed a bug when handling invalid serial number registration. # 1.0.1 * [-] Fixed ACL compatibility issues. (Reported by Rack911)

Screenshots

Reviews